Trackgen Plib SSG

Use this forum to report bugs or ask for help

Moderator: kilo

Trackgen Plib SSG

Postby simon-2 » Fri Jan 30, 2015 3:46 am

i got a Problem with sd2-trackgen...

it is exactly the same as this one: http://sourceforge.net/p/speed-dreams/mailman/message/27319241/ (crashes when trying to generate elevation map files saying "SSG: OpenGL will not accept a downsized version ?!?")
and probably related to this one http://ehc.ac/p/speed-dreams/mailman/message/28289141/. This link says, defining PROXY_TEXTURES_ARE_BROKEN for ssgLoadTexture.cpp could work, but for me, it did not work- but I'm not really sure if i did it right- does this mean to simply add
Code: Select all
#define PROXY_TEXTURES_ARE_BROKEN
to this file (and recompile PLib..)?

Another link (http://www.bsdforen.de/threads/supertuxkart-0-6-2.23471/) says, changing limits for xsize and ysize in ssgLoadTexture.cpp (and recompile..) could work, but it does not work for me neither...

Any Ideas?

Thanks, Simon
simon-2
 
Posts: 90
Joined: Thu Jan 29, 2015 3:01 pm

Re: Trackgen Plib SSG

Postby MiniJoe » Fri Jan 30, 2015 7:21 am

Hi Simon,
I run sd2-trackgen alot, do you have an xml file that will trigger the issue? If so, I'll try toduplicate the issue here. (on Windows)
Are you experiencing this on Linux?
Joe
MiniJoe
 
Posts: 100
Joined: Fri Mar 16, 2012 1:32 am

Re: Trackgen Plib SSG

Postby simon-2 » Fri Jan 30, 2015 4:38 pm

i used the Track "Nordschleife" as posted by user h-j-s here, have not edited anything yet, so i don't think it's a matter of the xml.
My target is to add terrain and a little bit of scenery to the track, and therefore generate the initial elevation maps, first.

I'm running it on Ubuntu 14.04..
simon-2
 
Posts: 90
Joined: Thu Jan 29, 2015 3:01 pm

Re: Trackgen Plib SSG

Postby MiniJoe » Fri Jan 30, 2015 8:06 pm

Hi Simon,
Three of the png's with that track have issues.
turn-20L.png
turn-1L.png
turn-2L.png
I tried following the instructions here:
http://sourceforge.net/p/speed-dreams/mailman/message/31888394/
but no joy.
I exported each as rgb files from GIMP.
Now sd2-trackgen will generate the heightmaps.
Hope this helps.
Cheers,
Joe
MiniJoe
 
Posts: 100
Joined: Fri Mar 16, 2012 1:32 am

Re: Trackgen Plib SSG

Postby simon-2 » Fri Jan 30, 2015 11:26 pm

thanks for your advice, but unfortunately, it did non change anything. Did you get the same error before converting these files?

Code: Select all
FATAL: SSG: OpenGL will not accept a downsized version ?!?


i even converted all png files in that folder to rgb for my next trial, but no success. Strange thing is, that
Code: Select all
sd2-trackgen -c road -n Nordschleife
(without the elevation argument) works fine, only when i try to get these files, it crashes :roll:
i also tried if the problem belongs to one specific elevation file, as i used -E 0 (all Files) in the beginning. But it occurs with every single elevation file...

edit:
same problem when using -a option...
simon-2
 
Posts: 90
Joined: Thu Jan 29, 2015 3:01 pm

Re: Trackgen Plib SSG

Postby MiniJoe » Fri Jan 30, 2015 11:51 pm

Yes, I got the exact same error. In fact, I can put the originals back and get the error again.
How did you convert the png's to rgb's? I opened them with GIMP (2.8), then exported to rgb keeping all the defaults.
MiniJoe
 
Posts: 100
Joined: Fri Mar 16, 2012 1:32 am

Re: Trackgen Plib SSG

Postby simon-2 » Sat Jan 31, 2015 12:04 am

i exported to rgb, uncompressed (RLE was default), also with Gimp 2.8. Then i moved the originals to a folder /bak to get rid of them. Very strange...
i will try it with RLE compression once before i go to sleep...

did you change anything else (links to these files, quadratic aspect ratio, ..)?

edit: does not work :roll:
simon-2
 
Posts: 90
Joined: Thu Jan 29, 2015 3:01 pm

Re: Trackgen Plib SSG

Postby MiniJoe » Sat Jan 31, 2015 12:44 am

simon-2 wrote:did you change anything else (links to these files, quadratic aspect ratio, ..)?

No. Very strange. I will email you the set that works here. Maybe you can try them tomorrow.
MiniJoe
 
Posts: 100
Joined: Fri Mar 16, 2012 1:32 am

Re: Trackgen Plib SSG

Postby simon-2 » Sat Jan 31, 2015 7:22 pm

argh, it seems i have shot my PLib now. Wondering why nothing changed after editing and compiling plib, i was stupid enough to rm all the plib-files in /usr/lib. The Problem is, that compiling Plib the normal way only creates the static libs (libplibXXX.a), but not dynamic versions (libplibXXX.so.1.8.5), which are needed by Speed Dreams. Now it makes sense, that all previous attempts of recompiling did not even have a chance to change anything...

Now i can not even play SD :(

compiling plib as described here does not bring back these files; this patch doesn't work, neither, and also (re-)installing package "libplib-dev" via synaptic does not offer the demanded files.

How can i get them back?? i can't believe that i have to install ubuntu again, just to get these libs back..? Also, it must be possible to compile plib in a way that dynamic versions are created?
simon-2
 
Posts: 90
Joined: Thu Jan 29, 2015 3:01 pm

Re: Trackgen Plib SSG

Postby MiniJoe » Sat Jan 31, 2015 8:47 pm

I don't remember having to do anything special to compile plib (you need -fPIC) on amd64.
I will search my notes.
Did you do an install after you built? I think 'make install' might create the .so files??
MiniJoe
 
Posts: 100
Joined: Fri Mar 16, 2012 1:32 am

Next

Return to Problems, Fixes & Help

Who is online

Users browsing this forum: No registered users and 3 guests

cron