Page 2 of 2

Re: argh... i killed my track

PostPosted: Mon Feb 22, 2016 5:52 pm
by simon-2
thanks, this fixed all of the bugs. I was sure i had used new style pits on another track before, but checking this revealed that all other tracks i did used the old style definition.
The first segment in the xml file can not be found for "start buildings"

following this hint, i also tried to place "start buildings" on the second or last track segment, none of them worked.
This implies, that trackgen has never been updated to cope with new style pit defs..?

with the old style def and an exaggerated race of 250 laps with simplix, usr and dandroid drivers (5 each), mixed car categories, only one of the simplixes was able to do a pit stop :x
workaround is to use old style def for trackgen and change the xml to new style afterwards, so at least some simplixes and some dandroids do pit stops...

but it could also be a result of another difficulty: the melco hairpin (tightest hairpin in the world..?). Most of the ai drivers can not take this one cleanly; so pile-ups are mandatory... so maybe some drivers omitted pitstops with -say- 2000 damage points (which is reasonable) and "collected" all of the remaining 8000 within the next lap, being stuck in melco hairpin...
is there a way to give additional input to the drivers to tell them how to drive?
Also, in real world there is a permanent yellow flag (no-passing zone) at this curve. Any way to implement this in SD?

another ai issue:
on the main straight, the usable width of the track consists of 7m main track and 7m right border, but only usr robots use the border...

(btw- as this commences a new issue, should i open a new thread or continue here?)

Re: argh... i killed my track

PostPosted: Fri Jul 22, 2016 8:49 am
by j.joo
The problem may be in the section (section R_a2)
เล่นพนัน มาตรฐานระดับโลก casino ลุ้นรับรางวัลแจ๊กพอต แจกเงินโบนัสแรกเข้า ทางเข้าcasino