Ordinary track : Seg fault

Discuss or share your track-related work here

Moderator: kilo

Ordinary track : Seg fault

Postby horo » Fri Jul 11, 2014 7:30 am

Hello,

I'm trying to make the simplest track possible for some tests. This track is the one created by default when the editor is started. I generated everything using tackeditor and trackgen.

Unfortunately, when I start this track, the program crash and I have just "Seg fault", that's quite little to debug. If you could try it and tell me if it works for you or just send me a runnable version.

I'm running SD on an Ubuntu 14.04.

Thanks for your attention.
You do not have the required permissions to view the files attached to this post.
horo
 
Posts: 13
Joined: Thu May 15, 2014 3:40 am

Re: Ordinary track : Seg fault

Postby mungewell » Fri Jul 11, 2014 3:24 pm

Puzzling... don't really have time to look in-depth, but it appears to run a practice lap OK (no segfault) on Win7 (32bit) although segfault may be triggered by one of your settings.

I note that you are missing the parameters 'sky version' and 'local info', which can be copied/tweaked from another track (such as Charmey)
Code: Select all
  <section name="Header">
    <attstr name="name"              val="Charmey"/>
    <attstr name="category"          val="road"/>
    <attnum name="version"           val="4"/>
   <attnum name="sky version" val="1"/>
    <attstr name="author"            val="CG, E. M. Jaeger"/>
    <attstr name="description"       val="Fast road track through the Swiss Alps"/>
  </section>

   <section name="Local Info">
      <attstr name="station" val="LSZB"/>
      <attnum name="overall rain likelyhood" unit="%" val="50"/>
      <attnum name="little rain likelyhood" unit="%" val="60"/>
      <attnum name="medium rain likelyhood" unit="%" val="20"/>
      <attnum name="time of day" unit="hour" val="14.0"/>
      <attnum name="sun ascension" unit="deg" val="100"/>
   </section>
mungewell
 
Posts: 307
Joined: Fri May 20, 2011 4:05 pm
Location: Southen Alberta, Canada

Re: Ordinary track : Seg fault

Postby horo » Thu Jul 17, 2014 4:26 am

Thank you very much. It's totally fine now.
horo
 
Posts: 13
Joined: Thu May 15, 2014 3:40 am

Re: Ordinary track : Seg fault

Postby horo » Thu Oct 02, 2014 6:32 am

... Sorry to bother you again. I have the same kind of problem but the previous solution doesn't change anything this time. Can any take a look at my xml file ?
You do not have the required permissions to view the files attached to this post.
horo
 
Posts: 13
Joined: Thu May 15, 2014 3:40 am

Re: Ordinary track : Seg fault

Postby horo » Fri Oct 03, 2014 5:32 am

I don't know why but the generation on Linux is still troublesome. But it's working on windows.

Sorry for the troubles.
horo
 
Posts: 13
Joined: Thu May 15, 2014 3:40 am


Return to SD Tracks

Who is online

Users browsing this forum: No registered users and 3 guests

cron